首页网络编程JavaScriptjavascript技巧 → Jscript识别IE浏览器

通过Jscript中@cc_on 语句识别IE浏览器及版本的代码

发布时间:2011-05-07 22:10:32 作者:

通过Jscript中@cc_on 语句识别IE浏览器及版本的代码,需要的朋友可以参考下。
激活条件编译支持。
@cc_on 备注
@cc_on 语句激活脚本引擎中的条件编译。
强烈推荐在注释中使用 @cc_on 语句,以使不支持条件编译的浏览器将您的脚本视为有效语法而接受它:
/*@cc_on*/
// The remainder of the script.或者,在注释外的一个 @if 或 @set 语句也将激活条件编译。
要求
版本 3
请参见
参考
@if...@elif...@else...@end 语句
@set 语句
复制代码 代码如下:

/*@cc_on
@if (@_jscript_version > 5.7)
document.write("You are using IE8+");
@elif (@_jscript_version == 5.7 && window.XMLHttpRequest)
document.write("You are using IE7");
@elif (@_jscript_version == 5.6 || (@_jscript_version == 5.7 && !window.XMLHttpRequest))
document.write("You are using IE6");
@elif (@_jscript_version == 5.5)
document.write("You are using IE5.5");
@else
document.write("You are using IE5 or older");
@end
@*/

概念
条件编译变量
其他资源
条件编译
IE的@cc_on条件编译

1: alert("浏览器版本为:"+sSuffix)

用来判断浏览器的版本很好用
var b = /*@cc_on!@*/false; 其中/*@cc_on ..... @*/
之间的部分可以被ie识别并作为程序执行,同时启用ie的条件编译。 最常用的变量是@_jscript_version:js版本,最后一位是ie主版本号
示例:

复制代码 代码如下:

var sSuffix = ( /*@cc_on!@*/false ) ? 'ie' : 'gecko' ;
/*@cc_on alert("显示浏览器版本号:"+@_jscript_version) @*/
alert(@_jscript_version)
alert("浏览器版本为"+sSuffix)

您可能感兴趣的文章:

相关文章
最新更新
业界资讯
网友评论