python

关注公众号 jb51net

关闭
首页 > 脚本专栏 > python > Requirement already satisfied解决

安装出现:Requirement already satisfied解决办法

作者:大彤小忆

最近pip install的时候报错,一大串Requirement already satisfied,所以下面这篇文章主要给大家介绍了关于安装出现:Requirement already satisfied的解决办法,需要的朋友可以参考下

遇到的问题:

当使用电脑中安装的Python 3.7的IDLE去运行某一个python文件时,会出现ModuleNotFoundError: No module named 'numpy'的报错,需要安装numpy库。

而当使用win+R快捷键打开cmd,输入pip install numpy命令时,却得到Requirement already satisfied: numpy in d:\programming\anaconda3\lib\site-packages (1.16.5)的提示,告诉我们已经有numpy存在于d:\programming\anaconda3\lib\site-packages (1.16.5)路径中,但是我们在IDLE中运行python文件时还是缺少numpy库。

分析原因,是因为已经存在的numpy库是存在于d:\programming\anaconda3\lib\site-packages (1.16.5)路径中,而我们的IDLE安装在d:\programming\Python37文件夹下,目前d:\programming\Python37\Lib\site-packages路径中是不存在numpy库的,所以运行python文件会报错。所以我们需要将numpy库安装在IDLE对应的路径下,才可以正常运行该python文件。

解决办法:

在cmd中使用pip install --target=目标路径 工具包名字格式的命令去安装所需要的库。例如,我使用pip install --target=d:/programming/Python37/Lib/site-packages numpy这个命令去安装numpy库,就可以成功安装。

重新在IDLE中运行之前的python文件,就可以正常运行了。

总结 

到此这篇关于安装出现Requirement already satisfied解决的文章就介绍到这了,更多相关Requirement already satisfied解决内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!

阅读全文