首页脚本专栏python → 正文内容 查看Python依赖包及其版本号信息

查看Python依赖包及其版本号信息的方法

发布时间:2019-08-13 17:02:04 作者:逸辰杳

今天小编就为大家分享一篇查看Python依赖包及其版本号信息的方法,具有很好的参考价值,希望对大家有所帮助。一起跟随小编过来看看吧

查看依赖包及对应的版本号信息的方法有两种:

方法1:pip list

方法2:pip freeze

这两个同时适用于Windows和Linux系统

当pip版本过低时,会出现list命令不存在,且freeze命令报错的情况。Eg:

有些Linux系统自带的Python环境所对应的pip版本为1.0.2,如下图所示:

在该环境下执行pip list,报 pip: error: No command by the name pip list 错误,如下图所示:

执行pip help可以发现,可执行命令中没有list,如下图所示:

执行pip freeze,错误提示如下图所示:

解决方案

将pip升级为最新版本即可;

命令:pip install --upgrade pip -i https://pypi.mirrors.ustc.edu.cn/simple

升级后,分别执行pip –version 和 pip help 查看版本和可执行命令:

然后执行pip list 或 pip freeze均可实现依赖及版本号查看。

以上这篇查看Python依赖包及其版本号信息的方法就是小编分享给大家的全部内容了,希望能给大家一个参考,也希望大家多多支持脚本之家。

您可能感兴趣的文章:

相关文章
最新更新
业界资讯
网友评论