首页软件编程易语言 → 正文内容 赋值定义多维数组

易语言赋值定义多维数组的代码实例

发布时间:2019-02-11 17:30:14 作者:易语言源码教程

今天小编就为大家分享一篇关于易语言赋值定义多维数组的代码实例,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧

赋值定义多维数组示例

.版本 2
.程序集 窗口程序集1
.子程序 _按钮_显示_被单击
.局部变量 a, 整数型, , "0"
.局部变量 c, 整数型, , "1,2"
.局部变量 b, 整数型
a = { 1, 12, 2, 22, 3, 32, 4, 42 }
.变量循环首 (1, 取整 (取数组成员数 (a) ÷ 2), 1, b)
  重定义数组 (c, 真, b, 2)
  c [b] [1] = a [b × 2 - 1]
  编辑框_显示.加入文本 (“C[” + 到文本 (b) + “][1] = ” + 到文本 (c [b] [1]) + #换行符)
  c [b] [2] = a [b × 2]
  编辑框_显示.加入文本 (“C[” + 到文本 (b) + “][2] = ” + 到文本 (c [b] [2]) + #换行符)
.变量循环尾 ()

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

相关文章
最新更新
业界资讯
网友评论