首页软件编程易语言 → 正文内容 易语言免费下载wps收费模板

易语言破解WPS的VIP模版下载地址

发布时间:2018-12-03 16:37:01 作者:易语言源码教程

今天小编就为大家分享一篇关于易语言破解WPS的VIP模版下载地址,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧

DLL命令表

.版本 2
.DLL命令 API下载文件, 整数型, "urlmon", "URLDownloadToFileA", , -下载文件
  .参数 pcaller, 整数型
  .参数 szurl, 文本型
  .参数 szfilename, 文本型
  .参数 dwreserved, 整数型
  .参数 lpfncb, 整数型

常量数据表

.版本 2
.常量 id, "<文本长度: 21>", , "big":[{"image_url":"

WPS VIP模板免费下载

.版本 2
.程序集 窗口程序集_启动窗口
.子程序 __启动窗口_创建完毕
.子程序 _按钮_开始解析_被单击
线程_启动 (&处理子程序)
.子程序 处理子程序
.局部变量 返回文本, 文本型
.局部变量 Hash, 文本型
.局部变量 address, 文本型
按钮_开始解析.禁止 = 真
按钮_开始解析.标题 = “解析中...”
返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (编辑框_地址.内容)))
Hash = 文本_取右边 (文本_取左边 (文本_替换 (文本_取出中间文本 (返回文本, #id, #引号), , , , “\”, “”), “_”), “preview/”)
address = “http://wdl1.cache.wps.cn/wps/cdnwps/upload/official/template/” + Hash
.如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.wpt”))), “KSOWS”, 假) < 1)
  下载子程序 (“wpt模版文件(*.wpt)”, “wpt”, address)
.否则
  .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.dpt”))), “KSOWS”, 假) < 1)
    下载子程序 (“dpt模版文件(*.dpt)”, “dpt”, address)
  .否则
    .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.ppt”))), “KSOWS”, 假) < 1)
      下载子程序 (“ppt文档(*.ppt)”, “ppt”, address)
    .否则
      .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.dps”))), “KSOWS”, 假) < 1)
        下载子程序 (“dps文档(*.dps)”, “dps”, address)
      .否则
        .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.pps”))), “KSOWS”, 假) < 1)
          下载子程序 (“pps文档(*.pps)”, “pps”, address)
        .否则
          .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.pot”))), “KSOWS”, 假) < 1)
            下载子程序 (“pot文档(*.pot)”, “pot”, address)
          .否则
            .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.pptx”))), “KSOWS”, 假) < 1)
              下载子程序 (“pptx文档(*.pptx)”, “pptx”, address)
            .否则
              .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.wps”))), “KSOWS”, 假) < 1)
                下载子程序 (“wps文档(*.wps)”, “wps”, address)
              .否则
                .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.doc”))), “KSOWS”, 假) < 1)
                  下载子程序 (“doc文档(*.doc)”, “doc”, address)
                .否则
                  .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.dot”))), “KSOWS”, 假) < 1)
                    下载子程序 (“dot文档(*.dot)”, “dot”, address)
                  .否则
                    .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.rtf”))), “KSOWS”, 假) < 1)
                      下载子程序 (“rtf文档(*.rtf)”, “rtf”, address)
                    .否则
                      .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.docx”))), “KSOWS”, 假) < 1)
                        下载子程序 (“docx文档(*.docx)”, “docx”, address)
                      .否则
                        .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.et”))), “KSOWS”, 假) < 1)
                          下载子程序 (“et文档(*.et)”, “et”, address)
                        .否则
                          .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.ett”))), “KSOWS”, 假) < 1)
                            下载子程序 (“ett文档(*.ett)”, “ett”, address)
                          .否则
                            .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.xls”))), “KSOWS”, 假) < 1)
                              下载子程序 (“xls文档(*.xls)”, “xls”, address)
                            .否则
                              .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.xlt”))), “KSOWS”, 假) < 1)
                                下载子程序 (“xlt文档(*.xlt)”, “xlt”, address)
                              .否则
                                .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.xlsx”))), “KSOWS”, 假) < 1)
                                  下载子程序 (“xlsx文档(*.xlsx)”, “xlsx”, address)
                                .否则
                                  .如果 (文本_取出现次数 (编码_utf8到gb2312 (到文本 (网页_访问 (address + “.xlsm”))), “KSOWS”, 假) < 1)
                                    下载子程序 (“xlsm文档(*.xlsm)”, “xlsm”, address)
                                  .否则
                                    信息框 (“解析地址失败...(1、是否解析了上传日期为2014年12月后的文档。2、你输入的地址输入错误。地址是要进入每篇文档的地址。3、接口被封了)”, 48, “OMG - 没解析到地址”, )
                                  .如果结束
                                .如果结束
                              .如果结束
                            .如果结束
                          .如果结束
                        .如果结束
                      .如果结束
                    .如果结束
                  .如果结束
                .如果结束
              .如果结束
            .如果结束
          .如果结束
        .如果结束
      .如果结束
    .如果结束
  .如果结束
.如果结束
按钮_开始解析.标题 = “开始解析”
按钮_开始解析.禁止 = 假
.子程序 下载子程序
.参数 过滤器, 文本型, , '过滤器
.参数 后缀名, 文本型
.参数 下载地址, 文本型
通用对话框.过滤器 = 过滤器
通用对话框.默认文件后缀 = 后缀名
通用对话框.打开 ()
API下载文件 (0, 下载地址 + “.” + 后缀名, 通用对话框.文件名, 0, 0)

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

相关文章
最新更新
业界资讯
网友评论