首页脚本专栏python → eclipse安装python插件pydev

详解如何为eclipse安装合适版本的python插件pydev

发布时间:2018-11-04 15:58:12 作者:赵小生z

这篇文章主要介绍了详解如何为eclipse安装合适版本的python插件pydev,pydev是一款优秀的Eclipse插件,具有一定的参考价值,感兴趣的小伙伴们可以参考一下

pydev是一款优秀的Eclipse插件,大多数喜欢在eclipse开发软件的程序员(也许是java程序员)在开发python软件时希望继续使用eclipse,那么pydev是非常理想的选择。

1、安装Pydev

在安装Pydev之前,首先要安装eclipse,可以在它的官方网站Eclipse.org找到并下载。当然,在执行Eclipse之前,必须确认是否正确安装了Java运行环境,即必须安装JRE或JDK,此处不再赘述。

运行Eclipse之后,选择help-->Install new Software,如下图所示。

点击Add,添加pydev的安装地址:http://pydev.org/updates/,如下图所示。安装旧版pydev需要添加安装地https://dl.bintray.com/fabioz/pydev/old/,并去掉选项Show only the lastest version of available software。

完成后点击"ok",接着点击PyDev的"+",展开PyDev的节点,要等一小段时间,让它从网上获取PyDev的相关套件,当完成后会多出PyDev的相关套件在子节点里,勾选它们然后按next进行安装。如下图所示。

安装完成后,重启Eclipse即可

3、设置Pydev

安装完成后,还需要设置一下PyDev,选择Window -> Preferences来设置PyDev。设置Python的路径,从Pydev的Interpreter - Python页面选择New

会弹出一个窗口让你选择Python的安装位置,选择你安装Python的所在位置。

完成之后PyDev就设置完成,可以开始使用。

4、Pydev的版本

安装完Pydev插件之后,有时我们会发现在Window -> Preferences下并没有PyDev选项,这是因为我们安装了与eclipse和JDK并不匹配的Pydev插件。

Pydev官方的说法是需要安装 java 8 and Eclipse 4.6 (Neon),当然,你也可以选择旧版的Eclipse/Java,但必须符合以下要求:

Eclipse 4.5, Java 8: PyDev 5.2.0Eclipse 3.8, Java 7: PyDev 4.5.5Eclipse 3.x, Java 6: PyDev 2.8.2

经过测试,Eclipse/Java必须同时高于上述版本,才能安装对应版本的PyDev。例如,eclipse4.3,java6,最高只能安装PyDev 2.8.2。

安装旧版pydev参考

在Eclipse中:

Help->Install New Software

add之后输入的链接地址 https://dl.bintray.com/fabioz/pydev/old/

如果使用从其他教程看到的链接 http://pydev.org/updates/,则只能搜索到最新的5.0.0版本,其他版本都看不到,即使去掉了show only the latest versions...选项。其实,我们可以打开链接 http://pydev.org/updates/,发现它直接跳转到了另一个链接https://dl.bintray.com/fabioz/pydev/5.0.0/,里面只有5.0.0版本的pydev资源。经过分析,发现,使用链接https://dl.bintray.com/fabioz/pydev/old/ 可以搜索到pydev的历史版本。

其余安装步骤与其他教程相同,此处略。

pydev安装的官方说明

http://www.pydev.org/manual_101_install.html

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持脚本之家。

您可能感兴趣的文章:

相关文章
最新更新
业界资讯
网友评论